Print Page | Close Window

Saving files from Excel without blank characters

Printed From: Just Flight Forum
Category: Just Flight Products
Forum Name: Traffic X / Traffic / Traffic 2005
Forum Description: Discussion area for Traffic titles
URL: http://forum.justflight.com/forum_posts.asp?TID=22512
Printed Date: 03 Jun 2020 at 10:01pm


Topic: Saving files from Excel without blank characters
Posted By: freddy
Subject: Saving files from Excel without blank characters
Date Posted: 14 Sep 2014 at 1:59am

In the Traffic 360 forum, RayM asked:

"Have you found a way to save a TrafficX TCC schedule file when using Excel so that there aren't loads of 'blank characters' that I have to edit out using 'Find & Replace' before TrafficX will open the file? I think that I have tried all of the different 'save as' options but haven't found one that saves a file that TrafficX will open directly. I love the way that Excel will produce sets of random numbers and/or letters to enable me to give all aircraft different registration and flight numbers."

Hmmm. That could depend on WHAT you're editing and HOW you're editing it.

I use Excel to edit flight plan files (the .TCC files found in the "Presets\Data\Schedules\Flight Plans" folder). To do this, first I take a BACKUP of the file I'm about to edit. That's very important in case something goes wrong. Then, I actually RENAME the file from a .TCC to a .XLS file. Now I open it in Excel, edit it, save it (as .TXT file), and then finally rename the file back from a .TXT to a .TCC file.

I am using Excel 2007. I don't know if what follows is because I am using that specific version or not ... but ... note that when I attempt to open this renamed file in Excel I get a message advising me that the file is in a different format than specific by the file extension ... blah, blah, blah ... do you want to open the file now? I respond YES and the file opens.

After editing the file, and then going to save it (as a .TXT file), I get ANOTHER message advising that the file may contain features that are not compatible with Text (Tab delimited). Note that for saving I merely accept the text file format that Excel is offering me at this point; and that is Text (Tab delimited). Excel asks if I want to keep the workbook in this format. I respond YES and save the file.

Depending on whether you are using the SAVE option within the program, or clicking the CLOSE button after making changes and expecting Excel to ask if you want to save, you MAY get a THIRD message at this point asking again if you want to save changes (even though you have probably just saved the file already). I always respond YES to that question, follow any further prompts from there, and (re)save the file (again) as a .TXT text file.

After all of that, I rename the file back from a .TXT to a .TCC file.

Using this method I've never had any additional 'blank characters' added. Maybe that's because, by renaming the file to a .XLS file, and then responding YES to the subsequent questions, the system then works on the file as if it were a native EXCEL file? I really don't know. But, the method I've described here has always worked for me and so I continue to do it this way.

I cannot see any reason why this method would not work with other Traffic X files as well (ie, not just the flight plan .TCC files).

---------------------------

A final note ...

I have made myself a small Readme.txt file for Traffic X which contains some things worth noting from the Just Flight Traffic X FAQ and a few other bits and pieces I've picked up along the way. One of the things in my Readme.txt file is this:

"Remember that Traffic X files are TEXT based files, but they must be saved using ANSI encoding."

I cannot recall where I saw that, or who said it, but I have found it to be correct and it is therefore handy to know.

That said, interestingly, in the case of me using Excel as per above, and saving my edited files as text files from Excel, I always just accept the text format that Excel offers me when I do the save ... and that is Text (Tab delimited). But, if I'm using Notepad or some other ASCII text editor to do my edits, I always make sure the file is saved in a text format that uses ANSI encoding.




Replies:
Posted By: RayM
Date Posted: 14 Sep 2014 at 2:18pm
Freddy you are a star! Just tried your simple method of editing TCC schedule files and, even though I am using Excel 2000, it works without any bother, no extra characters or anything that bothers the TrafficX TCC. I was making it far too complicated!
Copy file,
Rename to .xls,
Edit,
Save back to .xls (text - tab delimited),
Rename to .tcc, and
open in TCC and away we go!
Could not be simpler - saves me loads of time.
Many thanks.


-------------
A long time FSXA and Traffic X user


Posted By: freddy
Date Posted: 15 Sep 2014 at 12:43am
Excellent! I am glad it worked for you.

But ... oh no ... with the ability for you to edit more quickly and more efficiently now, I fear I may have created a monster.

But, I don't think that's such a bad thing.

Enjoy!




Print Page | Close Window